Обновляем Laravel Valet до PHP 7.4

Чтобы использовать Laravel Valet на свежей версии, сначала обновляем PHP на своей машине до версии 7.4. Для Mac вы можете использовать это замечательное руководство по обновлению PHP…

Однако, вы можете пойти более коротким путем используя homebrew.

Обновляем Brew

далее обновляем PHP

На этом этапе ваш компьютер должен уже использовать PHP 7.4, но Laravel Valet все еще может использовать PHP 7.3.

Обновление Valet

Обновляем composer

теперь обновляем Valet

теперь указываем использовать последнюю версию PHP

после этого разрываем связь с версией 7.3 или любой другой версией и используем самую свежую версию, 7.4 в нашем случае. Также вы можете указать свою версию для использования:

 

Подписаться на новые статьи